[mpich-discuss] Incorrect error message for MPID_nem_tcp_bind (1.5, 3.0.4)

Wesley Bland wbland at mcs.anl.gov
Wed Aug 7 22:53:48 CDT 2013

Thanks for the report. I've got a patch done now that should be going into the repository soon.


On Wednesday, August 7, 2013 at 4:37 PM, Yauheni Zelenko wrote:

> Hi!
> I have a problem on one host when MPID_nem_tcp_bind() failed with "MPID_nem_tcp_bind(580): unable to bind socket to port (port=1,errno=98:Address already in use)".
> However, MPID_nem_tcp_bind() tried to bind to port 0 (ports ranges was not specified), then failed, and port variable was incremented before final error message recorded.
> MPICH_PORT_RANGE helped to solve problem on aforementioned host.
> I tried version 1.5 and 3.0.4.
> Eugene.
> _______________________________________________
> discuss mailing list discuss at mpich.org (mailto:discuss at mpich.org)
> To manage subscription options or unsubscribe:
> https://lists.mpich.org/mailman/listinfo/discuss

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mpich.org/pipermail/discuss/attachments/20130807/96c38eb8/attachment.html>

More information about the discuss mailing list