[mpich-discuss] Incorrect error message for MPID_nem_tcp_bind (1.5, 3.0.4)

Yauheni Zelenko zelenko at cadence.com
Thu Aug 8 17:38:30 CDT 2013

Hi, Wesley!

Thank you for quick fix!

From: discuss-bounces at mpich.org [discuss-bounces at mpich.org] On Behalf Of Wesley Bland [wbland at mcs.anl.gov]
Sent: Thursday, August 08, 2013 2:57 PM
To: discuss at mpich.org
Subject: Re: [mpich-discuss] Incorrect error message for MPID_nem_tcp_bind (1.5, 3.0.4)

This has been resolved:


On Wednesday, August 7, 2013 at 10:53 PM, Wesley Bland wrote:

Thanks for the report. I've got a patch done now that should be going into the repository soon.


On Wednesday, August 7, 2013 at 4:37 PM, Yauheni Zelenko wrote:


I have a problem on one host when MPID_nem_tcp_bind() failed with "MPID_nem_tcp_bind(580): unable to bind socket to port (port=1,errno=98:Address already in use)".

However, MPID_nem_tcp_bind() tried to bind to port 0 (ports ranges was not specified), then failed, and port variable was incremented before final error message recorded.

MPICH_PORT_RANGE helped to solve problem on aforementioned host.

I tried version 1.5 and 3.0.4.

discuss mailing list discuss at mpich.org<mailto:discuss at mpich.org>
To manage subscription options or unsubscribe:

More information about the discuss mailing list