[mpich-discuss] Question on MPICH rpm for redat 5.6

Reuti reuti at staff.uni-marburg.de
Mon Jul 22 05:26:22 CDT 2013


Am 22.07.2013 um 11:50 schrieb McLeish, Allan:

> I’m currently having some issues installing MPICH on to our RHEL Linux system due to missing dependencies.
> I want to note that we use Redhat 5.6 and we don’t use YUM so our install is through the use of rpm’s.
> I initially tried installing the latest version of MPICH “mpich2-1.5-3.fc20.x86_64.rpm” but multiple dependencies where required so I tried going to an earliest version of MPICH available in the downloads “mpich2-1.0.8-3.fc11.x86_64.rpm” but this also was missing multiple dependencies.
> MPICH was a 3rd party app required for another program that we were requiring so I contacted there support and they suggested we used MPICH 1.4.1 as it worked the best with there program.

Instead of running into these dependencies it might be faster to compile MPICH on your own in the required version. Older version's source you can still get from:


> When I try to run the RPM for 1.4.1 is asks for multiple dependencies and each of those dependencies have dependencies, is there a tar with all the required dependancies for redhat 5.6 or are there any recommendations on how to go about this?
> rpm -ivh mpich2-1.4.1p1-9.fc18.x86_64.rpm
> error: Failed dependencies:
>         /usr/bin/bash is needed by mpich2-1.4.1p1-9.fc18.x86_64
>         environment-modules is needed by mpich2-1.4.1p1-9.fc18.x86_64
>         libc.so.6(GLIBC_2.14)(64bit) is needed by mpich2-1.4.1p1-9.fc18.x86_64
>         libc.so.6(GLIBC_2.15)(64bit) is needed by mpich2-1.4.1p1-9.fc18.x86_64

These depends on the version of GLIBC the RPM was created on. If it's compiled directly on the target system it might be better suited.

-- Reuti

>         libc.so.6(GLIBC_2.7)(64bit) is needed by mpich2-1.4.1p1-9.fc18.x86_64
>         libhwloc.so.5()(64bit) is needed by mpich2-1.4.1p1-9.fc18.x86_64
>         rpmlib(FileDigests) <= 4.6.0-1 is needed by mpich2-1.4.1p1-9.fc18.x86_64
>         rpmlib(PayloadIsXz) <= 5.2-1 is needed by mpich2-1.4.1p1-9.fc18.x86_64
> Many Thanks
> Allan
> Maersk Oil North Sea UK Limited, registered in England and Wales No. 03682299. Registered office Maersk House, Braham Street, London E1 8EP.
> This e-mail and any files transmitted with it are confidential and intended solely for the use of the individual or entity to which they are addressed. If you have received this e-mail in error please notify the system manager at hotline at maerskoil.com.
> _______________________________________________
> discuss mailing list     discuss at mpich.org
> To manage subscription options or unsubscribe:
> https://lists.mpich.org/mailman/listinfo/discuss

More information about the discuss mailing list