[mpich-discuss] Assembler messages at build ?

Huiwei Lu huiweilu at mcs.anl.gov
Sun Nov 24 00:51:33 CST 2013

On Nov 23, 2013, at 11:32 PM, Lou Picciano <loupicciano at comcast.net> wrote:

> Huiwei, Thanks for your ideas. Responses follow:
> ----- Original Message -----
> From: "Huiwei Lu" <huiweilu at mcs.anl.gov>
> To: discuss at mpich.org
> Sent: Saturday, November 23, 2013 10:04:23 PM
> Subject: Re: [mpich-discuss] Assembler messages at build ?
> Because I am not familiar with solaris, I will have some wild guesses here.
> 1. Does it has to be ‘-m32’? I searched a little bit and find SunOS 5.11 actually support 64 bit if the processor is 64 bit. Have you tried to configure and compile without ‘-m32’? What’s the output?
> Without CFLAGS or FFLAGS set, configure sets up a 32-bit build, with same Assembler messages as below.
> As an aside: When attempting an explicit configure for 64-bit:
> $ ./configure --prefix=/usr/local/mpi32 \
> FC=gfortran \
> F77=gfortran \
> CFLAGS="-m64" FFLAGS="-m64" \
> --with-pm=hydra \
> | tee c.txt
> configure: error: The selected Fortran 90 compiler gfortran does not work with the selected Fortran 77 compiler gfortran.  Use the environment variables FC and F77 respectively to select compatible Fortran compilers.  The check here tests to see if a main program compiled with the Fortran 90 compiler can link with a subroutine compiled with the Fortran 77 compiler.
> (same result without FC and F77 being set)

The very first error you reported seems to be caused by gcc. Let’s disable fortran first to see if gcc works in 64-bit. Try using the following command to disable fortran build:

./configure --disable-f77 --disable-fc

> 2. Can you give us the output of ‘isainfo -v’?
> 64-bit amd64 applications
>        vmx avx xsave pclmulqdq aes sse4.2 sse4.1 ssse3 popcnt tscp cx16 
>        sse3 sse2 sse fxsr mmx cmov amd_sysc cx8 tsc fpu 
> 32-bit i386 applications
>        vmx avx xsave pclmulqdq aes sse4.2 sse4.1 ssse3 popcnt tscp ahf 
>        cx16 sse3 sse2 sse fxsr mmx cmov sep cx8 tsc fpu

So it does support bit-64.

> 3. Have you tried the newest version of gcc? Because SunOS 5.11 is quite old now, maybe it is a bug in an old version of gcc which has been fixed.
> We're using 4.7.3, with some significant tweaks for the Illumos kernel. (We may be slipping away, at this point, from an 'exact match' test on SunOS 5.11!)

Seems *significant* tweak is needed to port newest gcc. I don’t know if it’s worth a try. Or have you seem this error happened while compiling other C source code instead of MPICH?

— Huiwei

More information about the discuss mailing list