[mpich-discuss] MPI weak symbols and gfortran

"Antonio J. Peña" apenya at mcs.anl.gov
Sat Jan 18 11:36:27 CST 2014


Hi Matthieu,

Please let us know the compilers an versions you are using, as well as a 
minimal code demonstrating the issue.

Best,
   Antonio


On 01/18/2014 07:44 AM, Matthieu Dorier wrote:
> Hi,
>
> I've overwritten some MPI_* functions in a C library (typically 
> MPI_Init and MPI_Finalize). When I link a C program with this library 
> using gcc, the overwritten symbols are called correctly. However when 
> using a fortran program, it does not work: the original functions are 
> called. When I do "nm myprog" I see that MPI_Init and PMPI_Init have 
> the same address, which is not the case with a C program. I also tried 
> to compile the fortran program into a .o file using gfortran, then use 
> gcc to link it to mpich, but I get the same result? Any workaround?
> Thanks!
>
> Matthieu Dorier
> PhD student at ENS Rennes
> http://people.irisa.fr/Matthieu.Dorier
>
>
> _______________________________________________
> discuss mailing list     discuss at mpich.org
> To manage subscription options or unsubscribe:
> https://lists.mpich.org/mailman/listinfo/discuss


-- 
Antonio J. Peña
Postdoctoral Appointee
Mathematics and Computer Science Division
Argonne National Laboratory
9700 South Cass Avenue, Bldg. 240, Of. 3148
Argonne, IL 60439-4847
apenya at mcs.anl.gov
www.mcs.anl.gov/~apenya

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mpich.org/pipermail/discuss/attachments/20140118/8da984aa/attachment-0001.html>


More information about the discuss mailing list