[mpich-discuss] couldn't build mpich-master-v3.1.1-56-g9d5ce23c on Solaris 10 x86_64 with gcc-4.9.0

Siegmar Gross Siegmar.Gross at informatik.hs-fulda.de
Sun Jul 6 04:52:52 CDT 2014


today I tried to build "mpich-master-v3.1.1-56-g9d5ce23c" on
"Solaris 10 x86_64" with gcc-4.9.0 in a 64-bit version. I was
able to configure the package with some warnings, but unable
to build it.

First I checked my file "log.configure.SunOS.x86_64.64_gcc" for
warnings. Some warnings can be avoided, if somebody has time to
change a few things in the configure script.

configure: WARNING: Unknown architecture i86pc... proceeding anyway

You can use "uname -p" or "uname -m" and then "isainfo -k" to
check if you build the package on a 32-bit or 64-bit processor
for "Solaris x86_64" .

sunpc1 fd1026 108 uname -s
sunpc1 fd1026 109 uname -p
sunpc1 fd1026 110 uname -m
sunpc1 fd1026 103 isainfo -k

I use the following code in the initialization script for my
heterogenous environment to determine the operating system and
processor architecture.

setenv SYSTEM_ENV `uname -s`
if (${SYSTEM_ENV} == Linux) then
  setenv MACHINE_ENV `uname -m`
  setenv MACHINE_ENV `uname -p`
  if ( (${SYSTEM_ENV} == SunOS) && (${MACHINE_ENV} != sparc) ) then
    if (`isainfo -k` == amd64) then
      setenv MACHINE_ENV "x86_64"

configure: WARNING: X11/Xutil.h: present but cannot be compiled
configure: WARNING: X11/Xutil.h:     check for missing prerequisite headers?
configure: WARNING: X11/Xutil.h: see the Autoconf documentation
configure: WARNING: X11/Xutil.h:     section "Present But Cannot Be Compiled"
configure: WARNING: X11/Xutil.h: proceeding with the compiler's result

You can compile "X11/Xutil.h" on Solaris if you include <X11/Xlib.h>
before including "X11/Xutil.h".

configure: WARNING: The ch3 device did not set the maximum size of
  an error string, 512 being used.
config.status: WARNING:
  seems to ignore the --datarootdir setting

I don't know if the above warnings are important or not.

Next I checked my file "log.make.SunOS.x86_64.64_gcc" and got the
following error.

  CC       adio/common/ad_prealloc.lo
  CC       adio/common/ad_read.lo
In file included from /usr/include/unistd.h:18:0,
  error: #error "Compiler or options invalid; UNIX 03 and POSIX.1-2001
  applications       require the use of c99"
 #error "Compiler or options invalid; UNIX 03 and POSIX.1-2001 applications \
make[3]: *** [adio/common/ad_read.lo] Error 1

I solved this problem setting CFLAGS to "-m64 -std=c11". Starting
once more with an empty directory, I got the same error as with

  CXX      src/binding/cxx/initcxx.lo
  CXXLD    lib/libmpicxx.la
ld: fatal: file libmpicxx.so.12: open failed: No such file or directory
ld: fatal: file processing errors. No output written to 
collect2: error: ld returned 1 exit status
make[2]: *** [lib/libmpicxx.la] Error 1

I would be grateful if somebody could provide a solution for my
problem. Do you need anything else? Thank you very much for any
help in advance.

Kind regards


More information about the discuss mailing list