[mpich-discuss] mpiexec and DISPLAY for remote hosts

Balaji, Pavan balaji at anl.gov
Tue Nov 11 18:44:22 CST 2014


Did you try passing -enable-x to mpiexec?

  — Pavan

> On Nov 11, 2014, at 5:00 PM, Isaila, Florin D. <fisaila at mcs.anl.gov> wrote:
> 
> Hi, 
> 
> I am having troubles running mpiexec (from MPICH 3.1) on remote hosts with xterm (for debugging purposes) from an Ubuntu box.
> 
> The following command works perfectly in local:
> mpiexec -n 1 xterm 
> 
> However, if I use a machine file: 
> mpiexec -f macfile -n 1 xterm 
> xterm Xt error: Can't open display: 
> xterm:  DISPLAY is not set
> 
> ===================================================================================
> =   BAD TERMINATION OF ONE OF YOUR APPLICATION PROCESSES
> =   PID 19225 RUNNING AT thwomp.mcs.anl.gov
> =   EXIT CODE: 1
> =   CLEANING UP REMAINING PROCESSES
> =   YOU CAN IGNORE THE BELOW CLEANUP MESSAGES
> ===================================================================================
> 
> X forwarding is activated:
> fisaila at howard:bin$ grep X11Forwarding /etc/ssh/sshd_config
> X11Forwarding yes
> 
> The following command works:
> fisaila at howard:bin$ ssh thwomp.mcs.anl.gov xterm
> 
> Any suggestion how to solve this?
> 
> Thanks
> Florin
> 
> 
> _______________________________________________
> discuss mailing list     discuss at mpich.org
> To manage subscription options or unsubscribe:
> https://lists.mpich.org/mailman/listinfo/discuss

--
Pavan Balaji  ✉️
http://www.mcs.anl.gov/~balaji



More information about the discuss mailing list