[mpich-discuss] Singleton init configuration for MPICH

Edric Ellis Edric.Ellis at mathworks.co.uk
Tue Aug 2 09:56:15 CDT 2016

Thanks for that Jeff. Are you referring to this discussion? http://lists.mpich.org/pipermail/devel/2016-July/000717.html If so, that shares some similarity with what I’m trying to recreate in MPICH. However, our code using MPICH2 makes no use whatsoever of mpiexec when in “connect/accept” mode, and I changing this would be rather invasive.

It seems as though that open issue has been open for quite a while now, with no scheduled release for when it might be addressed – so am I correct in understanding that there are no known workarounds, and that essentially my only option for now is to stick with MPICH2?


From: Jeff Hammond [mailto:jeff.science at gmail.com]
Sent: Monday, August 01, 2016 6:43 PM
To: MPICH <discuss at mpich.org>
Subject: Re: [mpich-discuss] Singleton init configuration for MPICH

It's an open issue: https://trac.mpich.org/projects/mpich/ticket/1074.

There was some discussion on the devel list as of last week that might be of interest to you.


On Mon, Aug 1, 2016 at 8:47 AM, Edric Ellis <Edric.Ellis at mathworks.co.uk<mailto:Edric.Ellis at mathworks.co.uk>> wrote:

I need to come up with an MPICH build that allows singleton-init processes to use MPI_Comm_connect/accept to get connected. Our MPICH2 build uses the “smpd” process manager to achieve this. However, now that we’re upgrading to MPICH (3.1.4), I notice that the “smpd” process manager no longer exists. Is there a combination of process manager and PMI that allows connect/accept for singleton-init processes? I’ve tried a few things and cannot seem to find a combination that works. Here are the things I’ve tried:

1.       Hydra with pmi=simple – fails when attempting to launch hydra’s mpiexec (I don’t have the message to hand, but my recollection is that hydra’s mpiexec didn’t accept “-pmi_args”)

2.       Hydra with pmi=pmi2/simple – cannot be built

3.       Gforker with pmi=pmi2/simple – required a couple of tweaks before it could be built, and then fails in PMPI_Init_thread complaining “Message truncated”

Is there some other combination that might work? Ideally, the singleton-init processes wouldn’t need to use mpiexec at all (as was the case with our MPICH2 build using smpd).


discuss mailing list     discuss at mpich.org<mailto:discuss at mpich.org>
To manage subscription options or unsubscribe:

Jeff Hammond
jeff.science at gmail.com<mailto:jeff.science at gmail.com>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mpich.org/pipermail/discuss/attachments/20160802/34d834a0/attachment.html>
-------------- next part --------------
discuss mailing list     discuss at mpich.org
To manage subscription options or unsubscribe:

More information about the discuss mailing list