[mpich-discuss] compile code with mpiexec in mingw on windows

Yi Pan panyi21hhu at gmail.com
Thu Mar 24 09:56:38 CDT 2016

Dear all,

I have been trying to compile some code (adcirc+swan) in mingw on windows,
one win 10 and one win 7.

I failed on both of them.

For win 10, I even could not run the example case cpi by mpiexec -n 4 cpi.
it says "error while connecting to host, no connection could be made
because the target machine actively refused it. (10061)". I tried many
solutions, including turning off the firewall, turning off the UAC, add a
environment variable MPIR_CVAR_CH3_PORT_RANGE to specify the port to the
same port that the mpi listening to... Non of them work.

For win 8, don't know what reason I could successfully run the example case
cpi by mpiexec -n 4 cpi. However, when I try to compile the code there's
another error: launch failed: CreatProcess(work -I ../prep -O2
"-mcmodel=medium" -ffixed-line-length-none "-march+cori7-avx" -m64 -static
-DREAL8 ............some flages here............ padcirc odir4/mkdir.o) on
'GodMapleTree' failed, error 5 - assess denied.
I tried something, e.g., turn off the UAC, give the administrator assess,
... I just won't work.

I know very little on the MPI. Could someone give me some tapes?


Best regards,

Yi Pan, PhD, Assistant Professor,
College of Harbor, Coastal and Offshore Engineering,
Hohai University,
1 Xikang Rd., Nanjing, Jiangsu 210098, China
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mpich.org/pipermail/discuss/attachments/20160324/982297a7/attachment.html>
-------------- next part --------------
discuss mailing list     discuss at mpich.org
To manage subscription options or unsubscribe:

More information about the discuss mailing list