[mpich-discuss] -configfile size limit?

Daily, Jeff A jeff.daily at pnnl.gov
Fri Jun 9 15:43:37 CDT 2017

I have been using mpiexec.hydra for launching non-MPI applications that communicate via ZeroMQ.  I use the configfile parameter, one line per application.  Here’s an example:

-n 1 -env FNCS_BROKER tcp://*:5570 fncs_broker 10
-n 1 -wdir R1_12_47_1_feeder_6 gridlabd R1_12_47_1_feeder_6.glm
-n 1 -wdir R1_12_47_1_feeder_7 gridlabd R1_12_47_1_feeder_7.glm
-n 1 -wdir R1_12_47_2_feeder_0 gridlabd R1_12_47_2_feeder_0.glm
-n 1 -wdir R1_12_47_2_feeder_1 gridlabd R1_12_47_2_feeder_1.glm
-n 1 -wdir R1_12_47_2_feeder_2 gridlabd R1_12_47_2_feeder_2.glm
-n 1 -wdir R1_12_47_3_feeder_4 gridlabd R1_12_47_3_feeder_4.glm
-n 1 -wdir R1_12_47_3_feeder_5 gridlabd R1_12_47_3_feeder_5.glm
-n 1 -wdir R1_12_47_4_feeder_8 gridlabd R1_12_47_4_feeder_8.glm
-n 1 -wdir R1_25_00_1_feeder_3 gridlabd R1_25_00_1_feeder_3.glm
-n 1 -wdir matpower ./start_MATPOWER case9.m real_power_demand.txt 18000 3600

This worked well for this smaller case.  I then tried a case with 15002 lines in my configfile, but I got a backtrace from mpiexec
*** glibc detected *** mpiexec: free(): invalid pointer: 0x0000000000736b10 ***

I’m guessing there is some size limit for the configfile?  Can anyone confirm and suggest a patch?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mpich.org/pipermail/discuss/attachments/20170609/738d6121/attachment.html>
-------------- next part --------------
discuss mailing list     discuss at mpich.org
To manage subscription options or unsubscribe:

More information about the discuss mailing list