[mpich-discuss] MPICH on ArchLinux

Guo, Yanfei yguo at anl.gov
Thu May 11 14:57:25 CDT 2017

Hi Lucas,

I just did a quick try on my archlinux box and I could not reproduce the problem. Can you provide more detail about the setup such as the number of nodes in your test? How to environment and environment variable is setup?

Yanfei Guo
Postdoctoral Researcher
MCS Division, ANL

On 5/11/17, 9:10 AM, "lucas.drei at web.de" <lucas.drei at web.de> wrote:

    Dear mpich,
    I experimented with MPICH and followed your install-guide.
    I use ArchLinux, SSH and NFS among other things.
    After the installation of mpich3.2 i tried to execute the example from your guide: "mpiexec -f machinefile hostname". 
    The command is executed and the terminal prints the hostname.
    But after the use of mpiexec several problems occur.
    When I try to use nano, the text editor closes immediately. But beneath the options(Save,help,exit....) it prints "SIGHUB or SIGTERM recived".
    When I try to use vi, the text editor prints repeatedly "AT E0F". Im also unable to install applications.
    Only after a reboot or exit, and then re-login im able to use a text editor or install an application again.
    When i tried the same thing with raspbian it seems to work.
    So maybe it could be an ArchLinux specific problem? What could be the problem?
    Thank you

discuss mailing list     discuss at mpich.org
To manage subscription options or unsubscribe:

More information about the discuss mailing list