[mpich-discuss] MPICH 3.4.1 and macOS 11.2 (aka Big Sur)

Allen Sanderson allen at sci.utah.edu
Thu Feb 18 15:53:42 CST 2021


First post to the discussion board. I made the mistake of upgrading to macOS 11.2 (aka Big Sur). I was able to build MPICH 3.4.1 successfully and integrate it with an application. However, when I ran, MPICH crashed. Here is the initial output:

Abort(1) on node 0: Internal error
0   libpmpi.12.dylib                    0x00000001068c2159 MPL_backtrace_show + 57
1   libpmpi.12.dylib                    0x000000010684e874 MPIR_Assert_fail + 36
2   libpmpi.12.dylib                    0x0000000106897bc8 MPIDI_OFI_mpi_init_hook + 4472
3   libpmpi.12.dylib                    0x00000001068790d3 MPID_Init + 3091
4   libpmpi.12.dylib                    0x00000001066ae70b MPIR_Init_thread + 219
5   libmpi.12.dylib                     0x00000001064bb897 MPI_Init + 279

I have not yet dug into the issue any further. Before doing so I wanted to first check to see if others have successfully built and run via macOS 11.2. If so I would appreciate any pointers. If it is known that it will not yet work, that would be good information as well so not to spend anytime digging.

I should note that on another machine, I was wiser and upgraded to macOS 10.5.7 (aka Catalina) and built and ran with 3.3.1 that worked fine running in parallel.



Allen Sanderson
SCI Institute
University of Utah

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mpich.org/pipermail/discuss/attachments/20210218/e6e77478/attachment.html>

More information about the discuss mailing list