[mpich-discuss] Issue with libcuda.a

Damiano Casalino - LR D.Casalino at tudelft.nl
Mon Jan 18 23:42:35 CST 2021

I undrrstand. Thanks.

On a parallel effort I tried to compile cuda and generate the static library, but the compilation failed because of a conflict between a function type in the library and the same function in a python header. After many issues that I had to face with CentOS-8, I must say that this OS is not really a good one!


From: "Zhou, Hui" <zhouh at anl.gov>
Date: Monday 18 January 2021 at 23:33
To: "discuss at mpich.org" <discuss at mpich.org>
Cc: Damiano Casalino - LR <D.Casalino at tudelft.nl>
Subject: Re: Issue with libcuda.a

I believe the official centos-8 distribution doesn’t have GPU support. The latest relase will support gpu when cuda library is detected during configure. Unfortunately, there isn’t an easy way to switch off cuda when the cuda is in the system path. Maybe try compile it in a container that doesn’t have cuda installed?

Hui Zhou

From: Damiano Casalino - LR via discuss <discuss at mpich.org>
Date: Monday, January 18, 2021 at 11:29 AM
To: discuss at mpich.org <discuss at mpich.org>
Cc: Damiano Casalino - LR <D.Casalino at tudelft.nl>
Subject: [mpich-discuss] Issue with libcuda.a
I have built mpich on a centos-8 gcc-8.3.1 machine and then tried to link it statically with my tools. The link failed because -lcuda was missing.

The same does not happen if I use mpich from the official centos-8 distrib.

Do you have any explanation about this behavior?

Thank you,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mpich.org/pipermail/discuss/attachments/20210119/9bce35ef/attachment.html>

More information about the discuss mailing list