[mpich-discuss] Compilation: MPICH3 and libxml2

Mogesh Naidoo MNaidoo4 at csir.co.za
Tue Nov 5 06:52:11 CST 2013

I'm having trouble compiling MPICH-3.0.4.
I'm using GNU 4.7.2 compilers.
My configure = 
./configure --prefix=/export/home/mnaidoo/software/mpich/mpich3_GNU --with-gnu-ld 2>&1 | tee c.txt
Configure is successful with no errors.
The make fails with 
"libtool: link: `/usr/lib64/libxml2.la' is not a valid libtool archive"
This occurs when trying:
"CCLD libhwloc_embedded.la"
So there's a libxml2.la in /usr/lib64, but there's also one in another directory.
I add this directory to LD_LIBRARY_PATH and I still get the same error.
How do I tell make to use the libxml2.la in the other directory?

This message is subject to the CSIR's copyright terms and conditions, e-mail legal notice, and implemented Open Document Format (ODF) standard. 
The full disclaimer details can be found at http://www.csir.co.za/disclaimer.html.

This message has been scanned for viruses and dangerous content by MailScanner, 
and is believed to be clean.

Please consider the environment before printing this email.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mpich.org/pipermail/discuss/attachments/20131105/0787cfc5/attachment.html>

More information about the discuss mailing list