[mpich-discuss] Compilation: MPICH3 and libxml2

Antonio J. Peña apenya at mcs.anl.gov
Tue Nov 5 12:44:11 CST 2013

Hi Mogesh,

We'll need some more information to be able to help you. What's your OS? 
Libtool version? Please also attach config.log and your complete c.txt. Your 
generated libtool script is going to be useful as well. I wonder why your 
libtool looks for that file at all.


On Tuesday, November 05, 2013 02:52:11 PM Mogesh Naidoo wrote:

I'm having trouble compiling MPICH-3.0.4.
I'm using GNU 4.7.2 compilers.
My configure = 
./configure --prefix=/export/home/mnaidoo/software/mpich/mpich3_GNU --
with-gnu-ld 2>&1 | tee c.txt
Configure is successful with no errors.
The make fails with 
"libtool: link: `/usr/lib64/libxml2.la' is not a valid libtool archive"
This occurs when trying:
"CCLD libhwloc_embedded.la"
So there's a libxml2.la in /usr/lib64, but there's also one in another 
I add this directory to LD_LIBRARY_PATH and I still get the same error.
How do I tell /make/ to use the libxml2.la in the other directory?
  -- This message is subject to the CSIR's copyright terms and conditions, e-
mail legal notice, and implemented Open Document Format (ODF) 
standard. The full disclaimer details can be found at 

*MailScanner[2]*, and is believed to be clean. 

[1] http://www.csir.co.za/disclaimer.html
[2] http://www.mailscanner.info/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mpich.org/pipermail/discuss/attachments/20131105/5f9f5bfe/attachment.html>

More information about the discuss mailing list