[mpich-discuss] Error building mpich-master-v3.1.2-131-gfa09f8e3 on Solaris 10 with gcc-4.9.0

Siegmar Gross Siegmar.Gross at informatik.hs-fulda.de
Tue Sep 2 12:17:35 CDT 2014


yesterday I tried to install mpich-master-v3.1.2-131-gfa09f8e3 on
my machines (Solaris 10 Sparc, Solaris 10 x86_64, and openSUSE
Linux 12.1 x86_64) with Sun C 5.12 and gcc-4.9.0 and failed with
the following errors for gcc on my Solaris platforms as well.

I configured once more with the following command.

tyr mpich-3.1.3-SunOS.sparc.64_gcc 254 head -8 config.log | grep mpich
  $ ../mpich-master-v3.1.2-131-gfa09f8e3/configure
  CC=gcc CXX=g++ F77=gfortran FC=gfortran CFLAGS=-m64 CXXFLAGS=-m64
  FFLAGS=-m64 FCFLAGS=-m64 LDFLAGS=-m64 -L/usr/lib/sparcv9
  -Wl,-rpath /usr/lib/sparcv9 --enable-f77 --enable-fc --enable-cxx
  --enable-romio --enable-debuginfo --enable-smpcoll
  --enable-threads=runtime --with-thread-package=posix --enable-shared

tyr mpich-3.1.3-SunOS.sparc.64_gcc 110 tail log.make.SunOS.sparc.64_gcc 
  CXX      src/binding/cxx/initcxx.lo
  CXXLD    lib/libmpicxx.la
ld: fatal: file libmpicxx.so.12: open failed: No such file or directory
ld: fatal: file processing errors. No output written to lib/.libs/libmpicxx.so.12.0.2
collect2: error: ld returned 1 exit status
make[2]: *** [lib/libmpicxx.la] Error 1
make[2]: Leaving directory `/export2/src/mpich-3.1.3/mpich-3.1.3-SunOS.sparc.64_gcc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/export2/src/mpich-3.1.3/mpich-3.1.3-SunOS.sparc.64_gcc'
make: *** [all] Error 2

I get the same error which I reported for mpich-3.1.2, if I use
"CFLAGS=-m64 -std=c11".

I would be grateful, if somebody can fix the problem. Thank you
very much for any help in advance.

Kind regards


More information about the discuss mailing list