[mpich-discuss] Running HPL on RPi cluster, seems like MPI is somehow not configured properly since it work with 1 node but not more

Heerdt, Lanze M. HeerdtLM1 at GCC.EDU
Tue May 26 15:32:24 CDT 2015

I realize this may be a bit off topic, but since what I am doing seems to be a pretty commonly done thing I am hoping to find someone who has done it before/can help since I've been at my wits end for so long they are calling me Mr. Whittaker.

I am trying to run HPL on a Raspberry Pi cluster. I used the following guides to get to where I am now:
and a bit of: https://www.raspberrypi.org/forums/viewtopic.php?p=301458#p301458 when the above guide wasn't working

basically when I run: "mpiexec -machinefile ~/machinefile -n 1 xhpl" it works just fine
but when I run "mpiexec -machinefile ~/machinefile -n 4 xhpl" it errors with the attached image. (if I use "mpirun..." I get the exact same behavior)
[Note: I HAVE changed the HPL.dat to have "2    Ps" and "2    Qs" from 1 and 1 for when I try to run it with 4 processes]

This is for a project of mine which I need done by the end of the week so if you see this after 5/29 thank you but don't bother responding

I have hpl-2.1, mpi4py-1.3.1, mpich-3.1, and openmpi-1.8.5 at my disposal
In the machinefile are the 4 IP addresses of my 4 RPi nodes

Any other information you need I can easily get to you so please do not hesitate to ask. I have nothing else to do but try and get this to work :P
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mpich.org/pipermail/discuss/attachments/20150526/54f542f9/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: HPL-error.PNG
Type: image/png
Size: 23435 bytes
Desc: HPL-error.PNG
URL: <http://lists.mpich.org/pipermail/discuss/attachments/20150526/54f542f9/attachment.png>
-------------- next part --------------
discuss mailing list     discuss at mpich.org
To manage subscription options or unsubscribe:

More information about the discuss mailing list