[mpich-discuss] Errors building MPICH on Windows 10 Ubuntu subsystem

Damian Rouson damian at sourceryinstitute.org
Tue Oct 11 09:45:12 CDT 2016

> On Oct 11, 2016, at 7:31 AM, Balaji, Pavan <balaji at anl.gov> wrote:
>> On Oct 11, 2016, at 2:05 PM, Damian Rouson <damian at sourceryinstitute.org> wrote:
>>> On Oct 10, 2016, at 5:10 PM, Balaji, Pavan <balaji at anl.gov> wrote:
>>> Can you try building with --disable-maintainer-mode?
>> Yes, I tried building with “—disable-maintainer-mode” after reading the link stackoverlow link that I forwarded.  It also recommended disabling maintainer mode.
> Are you still having the problem even with that configure option?


>  Did you try deleting and reinstalling from scratch?

Yes, several times.

> Also, if you have Ubuntu, can you simply apt-get install mpich?

On this system, apt-get installs GCC 4.8.  My goal is to support users of OpenCoarrays, which requires at least GCC 5.1.0 and preferably GCC 6.1.0.  Is there a Debian dpkg file that I could use to install MPICH? 

Strangely, I can also report that building OpenMPI from source leads to the same error message.  By contrast, I am able to build GCC 6.1.0 and CMake 3.4.0 from source with no problems so not all builds fail.


discuss mailing list     discuss at mpich.org
To manage subscription options or unsubscribe:

More information about the discuss mailing list