[mpich-discuss] make testing fails when building from git(main)

Gregor Corbin g.corbin at fz-juelich.de
Thu Dec 16 11:48:20 CST 2021

Dear MPICH devs,

I want to use the MPI test suite provided with MPICH to test an MPI 
wrapper library I am developing (the MPI wrapper for Score-P).

As a first step, I tried to check out the latest version from git, build 
everything and then run the test suite with `make testing`. I can build 
MPICH itself without a problem and the example cpi program runs just 
fine. However, during `make testing` I run into lots of errors of the form

    In file included from dtpools.c:6:
    ../include/dtpools_internal.h:12:10: fatal error: mpi.h: No such
    file or directory
        12 | #include "mpi.h"
           |          ^~~~~~~
    compilation terminated.

This happens only with the git version, not with the tarball 

I attached all the program outputs and log files. Any help is appreciated.

As I workaround I first built MPICH itself, then did './configure 
CC=mpicc ...', in the test/mpi directory and then directly use the 
runtests script. This works for now, but is surely not how it was intended.

Kind regards,

Gregor Corbin

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mpich.org/pipermail/discuss/attachments/20211216/a14eedb9/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: mpich-logs.tar.gz
Type: application/gzip
Size: 262735 bytes
Desc: not available
URL: <http://lists.mpich.org/pipermail/discuss/attachments/20211216/a14eedb9/attachment-0001.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 5900 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://lists.mpich.org/pipermail/discuss/attachments/20211216/a14eedb9/attachment-0001.p7s>

More information about the discuss mailing list