[mpich-discuss] make testing fails when building from git(main)

Zhou, Hui zhouh at anl.gov
Thu Dec 16 13:59:40 CST 2021

Could you try with the latest git repo? We just merged this PR https://github.com/pmodels/mpich/pull/5722 to fix this issue.

FYI, we have changed the way we configure test suite. In the main branch, test suite, i.e. test/mpi​, is now configured independently from the mpich configure. To run test suite, after build and installing mpich, go to test/mpi​, run
     make testing

We added rule in the mpich Makefile so make testing​ will do above as a convenience. But if you encounter issues or need customized test configuration, try configure test/mpi separately.

Hui Zhou
test/config: minor fixes by raffenet · Pull Request #5722 · pmodels/mpich<https://github.com/pmodels/mpich/pull/5722>
Pull Request Description Improve configure output Fix dtpools build issue Author Checklist Provide Description Particularly focus on why, not what. Reference background, issues, test failures, ...

From: Gregor Corbin via discuss <discuss at mpich.org>
Sent: Thursday, December 16, 2021 11:48 AM
To: discuss at mpich.org <discuss at mpich.org>
Cc: Gregor Corbin <g.corbin at fz-juelich.de>
Subject: [mpich-discuss] make testing fails when building from git(main)

Dear MPICH devs,

I want to use the MPI test suite provided with MPICH to test an MPI wrapper library I am developing (the MPI wrapper for Score-P).

As a first step, I tried to check out the latest version from git, build everything and then run the test suite with `make testing`. I can build MPICH itself without a problem and the example cpi program runs just fine. However, during `make testing` I run into lots of errors of the form

In file included from dtpools.c:6:
../include/dtpools_internal.h:12:10: fatal error: mpi.h: No such file or directory
   12 | #include "mpi.h"
      |          ^~~~~~~
compilation terminated.

This happens only with the git version, not with the tarball version(mpich-4.0b1).

I attached all the program outputs and log files. Any help is appreciated.

As I workaround I first built MPICH itself, then did './configure CC=mpicc ...', in the test/mpi directory and then directly use the runtests script. This works for now, but is surely not how it was intended.

Kind regards,

Gregor Corbin

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.mpich.org/pipermail/discuss/attachments/20211216/a0e96969/attachment.html>

More information about the discuss mailing list